extend schema to support fields required by UIU-31
Description
Environment
Potential Workaround
blocks
relates to
Checklist
hideTestRail: Results
Activity

Jakub Skoczen June 15, 2017 at 11:57 AM
Yes, createdDate and updatedDate. If those are the name you have used, the issue is fixed.

Niels Erik Nielsen June 14, 2017 at 10:57 AM
I was not quite sure about that either but I think for this jira it's just changing the schema like you say.
Pretty sure the names we landed on were createdDate
and updatedDate
, though (FOLIO-592)

Kurt Nordstrom June 13, 2017 at 8:32 PM
Guys, I'm a little confused about the scope of this issue. Given that we have separate issues to A) define the date format and B) handle populating the date timestamps in mod-user, is the only thing I'm doing changing the names of "openDate" and "lastUpdateDate" to "created" and "lastUpdated" respectively?

shale99 May 25, 2017 at 12:19 PM
i agree, i dont think the created and updated fields should necessarily serve a business purpose - but they probably will in many cases - i would assume that a loan is created when a loan for an item is made and not before - so that this field can serve not only in auditing but to even 'sort by', reporting, etc...
but i think that you are correct in saying this should be considered on a per use case basis, if we run into cases where a record is created in the database , but there is a need to have an additional creation date for some reason, in such cases there will need to be a more business oriented create_date_field

Marc Johnson May 25, 2017 at 12:10 PM
I agree that standardising on the names of these properties is a good idea, both from the perspective of a client to the APIs and for reuse of logic.
To me, created and last update information is generally used for auditing or history tracking purposes. I personally think we need be cautious using the same properties for domain state (this has caused me many challenges in the past).
For example, in the case of a loan, I believe there is a distinction between when an item is loaned and when the record about that loan is created (they might be the same / very similar much of the time) and therefore would hope the API provided them separately.
I don't know enough about the users domain to know if open date is a domain concept or an alternative name to created, so it is difficult for me to comment on that.
Unlike what we have decided in MODUSERS-15 we want the schema to be extended with timestamp fields "lastUpdated" and "created". The header based solution would not be sufficient to deal with lists of records (like /users) and we will most likely need timestamps there.